Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > BeastX FBL System


BeastX FBL System BeastX FBL Flybarless System Software and Hardware Support


Like Tree12Likes
  • 3 Post By Gyropilot
  • 3 Post By sutty
  • 3 Post By joshblues21
  • 3 Post By joshblues21
Reply
 
LinkBack Thread Tools Display Modes
Old 05-24-2021, 04:48 PM   #1 (permalink)
Registered Users
 

Join Date: Jun 2015
Location: Tehachapi, CA
Default AR7200BX Random Oscillations

Hi All,

Curious if anyone has experienced similar issues and was able to remedy. Searching the forum, I couldn't find anyone with the same issue.

Have a Rave ENV Nitro (700 size) with the AR7200BX. Heli has had 50+ flights and has always flown beautifully, never had an issue whatsoever with the AR7200. I've been out of the hobby for six years - just got back in. I've flown 3 tanks of fuel after getting everything flight worthy again and it's flown absolutely perfect - until tank 4 yesterday.

Whilst brining it into a hover to land, I got violent oscillations on both elevator and aileron - like the P gain was too high. Was able to bring it down, dialed back the cyclic gain and checked all mechanicals/tape/etc. Same problem as soon as I hover, but now with random collective jumps both + and -. Ended up with a hard landing, broke my landing gear and got lucky that the heli was able to lean against the exhaust pipe which kept it from turning into a new airframe. Not even a scratch on the blades!

Odd thing is - I don't have weird vibes, or static (torque tube tail). Think the 'ol 7200 may just be at end of life?
joshblues21 is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-24-2021, 06:37 PM   #2 (permalink)
Registered Users
 
Posts: 745
 

Join Date: Dec 2014
Location: Pacific NW to Desert SW in the USA
Default

Wow! That sounds pretty scary.

I dont have any good suggestions for you, but I do have a spare AR7200BX laying around that you can HAVE if you decide you'd like to try swapping it out. Just PM me your postal mailing address and I'll send it to you.

John L.
sutty, joshblues21 and Cyclone7 like this.
Gyropilot is offline        Reply With Quote Quick reply to this message
Old 05-24-2021, 07:02 PM   #3 (permalink)
Registered Users
 
Posts: 11,779
 
My HF Map location
Join Date: Feb 2008
Default

No point adjusting any settings. If it flew beautifully for 50 flights, and then flew another 3 tanks after a long layoff, it should have been the last thing to do, if at all.

Glad you got away without major damage. If it were my issue, I would look for far more basic things, like cleaning all the contacts/plugs, with contact cleaner. Checking and or replacing the tape for the MB. Might well have disintegrated with a bit of oil absorbed by it 6 years ago.

If it's still very smooth, probably not any bearings, but still, 6 years is a long time to sit in one place.

Last, how about cleaning your radio pots, or have they not been sitting still for 6 years? At least check your output monitor, on collective, and see if it jumps around.

By the way, jumping around on collective could be one servo, sticking or jumping. FBL units are very clever, in that if one servo doesn't move, or is slow, it moves all the others to match, because cyclic takes precedence over collective.

It's just the way it is. It has to keep the rate correct on the cyclic, so if the rate was zero, for example, level, and you add collective, and one servo doesn't move properly, the others can't move either. If it twitches down, they will follow to keep it level. If one twitches up and down a lot, they will too.

So, check all your servos too. Clean pots, moving correctly and smoothly, on the deck, even when engine running, etc.

Other than that, which is all very general, I have no other suggestions, but if you can borrow Gyropilot's unit, that would be fantastic help in fault finding.

I'd probably put it on a different, smaller, read cheaper, heli, in order to check it out with other components, external to the FBL.
__________________
Regards, Sutty
BeltEXI, mCX, mSR, 4G3, FBL Trex250SE B, FBL Trex450Pro B,
FBL Trex550e VX1 Pro, FBL Trex600ESP VX1e, Parkzone P51D, QRX350Pro
sutty is offline        Reply With Quote Quick reply to this message
Old 05-24-2021, 07:24 PM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2015
Location: Tehachapi, CA
Default

Quote:
Originally Posted by Gyropilot View Post
Wow! That sounds pretty scary.

I dont have any good suggestions for you, but I do have a spare AR7200BX laying around that you can HAVE if you decide you'd like to try swapping it out. Just PM me your postal mailing address and I'll send it to you.

John L.
Thanks! I do have another AR7200BX on my Raptor FBL conversion that still flies great, so I'll swap that one around to test.
joshblues21 is offline        Reply With Quote Quick reply to this message
Old 05-24-2021, 07:30 PM   #5 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2015
Location: Tehachapi, CA
Default

Quote:
Originally Posted by sutty View Post
No point adjusting any settings. If it flew beautifully for 50 flights, and then flew another 3 tanks after a long layoff, it should have been the last thing to do, if at all.

Glad you got away without major damage. If it were my issue, I would look for far more basic things, like cleaning all the contacts/plugs, with contact cleaner. Checking and or replacing the tape for the MB. Might well have disintegrated with a bit of oil absorbed by it 6 years ago.

If it's still very smooth, probably not any bearings, but still, 6 years is a long time to sit in one place.

Last, how about cleaning your radio pots, or have they not been sitting still for 6 years? At least check your output monitor, on collective, and see if it jumps around.

By the way, jumping around on collective could be one servo, sticking or jumping. FBL units are very clever, in that if one servo doesn't move, or is slow, it moves all the others to match, because cyclic takes precedence over collective.

It's just the way it is. It has to keep the rate correct on the cyclic, so if the rate was zero, for example, level, and you add collective, and one servo doesn't move properly, the others can't move either. If it twitches down, they will follow to keep it level. If one twitches up and down a lot, they will too.

So, check all your servos too. Clean pots, moving correctly and smoothly, on the deck, even when engine running, etc.

Other than that, which is all very general, I have no other suggestions, but if you can borrow Gyropilot's unit, that would be fantastic help in fault finding.

I'd probably put it on a different, smaller, read cheaper, heli, in order to check it out with other components, external to the FBL.
Thanks Sutty, I did just check the Tx, all good on the output. I flew another one of my helis the same day with no issue.

I didn't even think about a single servo potentially causing this, that makes a lot of sense. On the bench it acted normal so I'll plan on spinning up w/o blades to see what it does and clean plugs etc. to see if behavior changes. May need to buy a servo tester...
joshblues21 is offline        Reply With Quote Quick reply to this message
Old 05-24-2021, 08:05 PM   #6 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2015
Location: Tehachapi, CA
Default

Well, on closer inspection - the rubber dampeners used when mounting the cyclic servos have disintegrated. I have lots of movement on 2 of the 3.

Will start with that. Thanks again guys.
sutty, Gyropilot and Cyclone7 like this.
joshblues21 is offline        Reply With Quote Quick reply to this message
Old 05-25-2021, 03:44 AM   #7 (permalink)
Registered Users
 
Posts: 2,787
 

Join Date: Nov 2017
Location: Lincolnshire, United Kingdom.
Default

That sounds to be the most likely cause.
Cyclone7 is offline        Reply With Quote Quick reply to this message
Old 05-25-2021, 06:56 AM   #8 (permalink)
Registered Users
 
Posts: 11,779
 
My HF Map location
Join Date: Feb 2008
Default

Sounds like a reasonable match for the symptoms you described. Let us know how you make out once you have those grommets swapped out. Good luck.
__________________
Regards, Sutty
BeltEXI, mCX, mSR, 4G3, FBL Trex250SE B, FBL Trex450Pro B,
FBL Trex550e VX1 Pro, FBL Trex600ESP VX1e, Parkzone P51D, QRX350Pro
sutty is offline        Reply With Quote Quick reply to this message
Old 06-08-2021, 10:30 PM   #9 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2015
Location: Tehachapi, CA
Default

Well, still waiting for the landing gear to show up for the Rave... may be time to get a modern bird...
joshblues21 is offline        Reply With Quote Quick reply to this message
Old 06-14-2021, 01:06 PM   #10 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2015
Location: Tehachapi, CA
Default

Rigged some Align 700 landing gear to get a flight, (to which it broke on first landing due to the extra holes I drilled to mount) and it flew beautiful once again! Servo mounting rubber was the culprit.
sutty, Gyropilot and Cyclone7 like this.
joshblues21 is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1