Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Spektrum FBL System > Spektrum FC6250HX



Like Tree1Likes
  • 1 Post By HuiHui
Reply
 
LinkBack Thread Tools Display Modes
Old 10-24-2020, 10:52 PM   #1 (permalink)
Registered Users
 
My HF Map location
Join Date: Jan 2005
Location: Delaware
Question 6250HX and SM-Modellbau UniSens-E

Hi there! I suppose this is mainly geared toward Brian, but I'd be happy to hear from anyone that has any advice or experience...

I'm currently working on a T-Rex 650X. Previously I was using a Microbeast Plus Pro FBL with a 8010T Rx. I ran the RPM output from my Align 140A (basically a HW Platnum v4) to the 8010T as well as a tap to my flight pack. This gave me telemetry back for both headspeed and flight pack voltage.

Originally I had planned on building this out with the FC6250HX, but encountered a dead unit before I had a chance, so went with the MB/8010T instead while waiting for the replacement.

Once the new 6250HX came in, I finally (today) had a chance to replace the MB/8010T.

Now originally I knew the only input for telemetry from the 6250HX was the xbus, so I had purchased the SM-Modellbau UniSens-E along with the Spektrum Adaptor they make. This converts the telemetry data from the UniSens-E (RPM, FP Voltage, Amp draw, battery capacity used, along with vario and some other features not really applicable to my heli, but there none the less) into Spektrum xbus.

Basically the link from the UniSens-E plugs into the spektrum adaptor, and it provides an xbus output for spektrum.

I've went through the setup in the UniSens-E software and made sure everything was set correctly... It's set to output spektrum xbus telemetry...

However it just doesn't work... I get absolutely no telemetry from it through the 6250HX.

Any ideas or suggestions???
rusirius is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-25-2020, 09:09 AM   #2 (permalink)
HF Scale Support
 
Posts: 4,072
 

Join Date: Jan 2010
Default

Hi,

I presume that you bound with auto telemetry enabled? Also, the only way that telemetry gets output is when the 4651T is connected and bound to the 6250. Lastly, if you had telemetry at binding, then you may need to manually go back and have the transmitter discover the telemetry devices once again. Just a few things to check that may help sort it out.

Don
Keyrigger is online now        Reply With Quote Quick reply to this message
Old 10-25-2020, 04:08 PM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2005
Location: Delaware
Default

Quote:
Originally Posted by Keyrigger View Post
Hi,

I presume that you bound with auto telemetry enabled? Also, the only way that telemetry gets output is when the 4651T is connected and bound to the 6250. Lastly, if you had telemetry at binding, then you may need to manually go back and have the transmitter discover the telemetry devices once again. Just a few things to check that may help sort it out.

Don
Yup, it picked up the standard 3 packets from the FC6250HX itself, but nothing else... and none of those packets have any of the data from the UniSens-E. I also tried rescanning several times. I have an 8010T as well as I mentioned, so I'm going to try to hook that up and see what I can get out of that...
rusirius is offline        Reply With Quote Quick reply to this message
Old 10-25-2020, 04:55 PM   #4 (permalink)
Registered Users
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2005
Location: Delaware
Default

Ok, I've now confirmed that the UniSens-E works perfectly fine with the 8010T. I hooked it up to the xbus port on the 8010T and bound it up and all the telemetry data was there with no problem at all. I also noticed that the LED on the spektrum adaptor was constantly flashing red (I'm assuming indicating packets), whereas when it's connected to the xbus on the FC6250HX I get absolutely nothing... No data and no flashing LED on the adaptor...

So it looks like there is some kind of difference between the FC6250HX xbus and the normal spektrum xbus... Hopefully Brian can elaborate and hopefully help get this resolved!
rusirius is offline        Reply With Quote Quick reply to this message
Old 10-26-2020, 10:12 AM   #5 (permalink)
Registered Users
 

Join Date: Sep 2010
Default

Updating the fc6250hx to SPEKTRUMô FC6250HX OPEN STOCK VERSION 5.5.0 PUBLIC BETA (JUNE19TH, 2020) firmware should take care of the issue. The detection of xbus sensors was changed to a slower concurrent process that is more reliable.

If the sensor is working on the 8010t it will work on the fc6250hx after the firmware update.

As mentioned in the v5.5 release notes make sure you fwd prg->system setup->calibrate sensor after this update or anytime you change the sensor orientation. Exiting the orientation setting menu will lead you to the calibration step as well.

Regards,
__________________
Horizon Hobby, LLC
My Projects: 150 S, 200 SRX, 200 S, 230 S v1/v2, 270 CFX, Fu270, Fu480: AR636/AR6335 Heli, FC6250HX, AR6250MHX
brianbremer is offline        Reply With Quote Quick reply to this message
Old 10-26-2020, 09:39 PM   #6 (permalink)
Registered Users
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2005
Location: Delaware
Default

Quote:
Originally Posted by brianbremer View Post
Updating the fc6250hx to SPEKTRUMô FC6250HX OPEN STOCK VERSION 5.5.0 PUBLIC BETA (JUNE19TH, 2020) firmware should take care of the issue. The detection of xbus sensors was changed to a slower concurrent process that is more reliable.

If the sensor is working on the 8010t it will work on the fc6250hx after the firmware update.

As mentioned in the v5.5 release notes make sure you fwd prg->system setup->calibrate sensor after this update or anytime you change the sensor orientation. Exiting the orientation setting menu will lead you to the calibration step as well.

Regards,
Thanks for the response Brian... I should have mentioned that in the original post, but unfortunately I had already updated to 5.5... Initially when it wasn't working I checked to see if there was an update, and was rather excited to see mention in the release notes of telemetry fixes... Unfortunately even on 5.5 it doesn't work.

So now I have a bit of a conundrum... I'm on 5.5, and it definitely works with the 8010T, but it's not working at all with the 6250HX...

Next step?
rusirius is offline        Reply With Quote Quick reply to this message
Old 10-27-2020, 12:06 PM   #7 (permalink)
Registered Users
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2005
Location: Delaware
Default

Here's a video I shot showingthe telemetry on the 8010T working and the 6250HX not working with no changes at all, just swapped from one to the other and you'll see it just won't work at all with the xbus on the 6250HX...

6250HX xbus vs 8010T xbus (5 min 28 sec)
rusirius is offline        Reply With Quote Quick reply to this message
Old 10-27-2020, 08:02 PM   #8 (permalink)
Registered Users
 

Join Date: Sep 2010
Default

At 3:27, did you say the led did not do the slow flash? or did do the slow flash? I rewound a few times but could not determine exactly what was said. Just trying to determine if the power up was different between the fc6250/8010t.

I have tested most of our xbus sensors and the castle telemetry link and all reliably connect and work without issue on v5.5.

Since I do not have a unisens adapter or unisens telemetry devices the best I can do is build a special firmware for you to test that varies the sensor enumeration timing(s) and see if it helps to resolve the issue.

I cannot guarantee this is a one and done deal so you may have to test a few different versions, without hardware on hand it is a bit of a guessing game.

It will be a couple of days before I can build and send over the special firmware to test this. If you want to go this route PM me your email and I will send a link to the firmware once it is ready.

Regards,
__________________
Horizon Hobby, LLC
My Projects: 150 S, 200 SRX, 200 S, 230 S v1/v2, 270 CFX, Fu270, Fu480: AR636/AR6335 Heli, FC6250HX, AR6250MHX
brianbremer is offline        Reply With Quote Quick reply to this message
Old 10-27-2020, 10:21 PM   #9 (permalink)
Registered Users
Thread Starter Thread Starter
 
My HF Map location
Join Date: Jan 2005
Location: Delaware
Default

Quote:
Originally Posted by brianbremer View Post
At 3:27, did you say the led did not do the slow flash? or did do the slow flash? I rewound a few times but could not determine exactly what was said. Just trying to determine if the power up was different between the fc6250/8010t.
Sorry about that... No, the startup was exactly the same... The slow flash takes place, which I think is just the spektrum adaptor saying it's "initialized"... But with the 8010T after it goes out for a second after that it starts blinking non-stop (I'm assuming showing packets) but with the 6250HX it just goes out completely...

Quote:
Originally Posted by brianbremer View Post
Since I do not have a unisens adapter or unisens telemetry devices the best I can do is build a special firmware for you to test that varies the sensor enumeration timing(s) and see if it helps to resolve the issue.

I cannot guarantee this is a one and done deal so you may have to test a few different versions, without hardware on hand it is a bit of a guessing game.
I'm a tinkerer... LOL, so I'd be more than happy to test out anything I can... My job is in IT, but I've got a pretty strong electronics background as well... If it would help in any way I could hook up a scope to the signal line if there is anything there I can look for that might help... I'm assuming the xbus uses I2C? In a worse case scenario if the different builds don't help I could probably even rig up some sort of I2C decoder to try to capture the packets and see exactly what is being sent by whom and when...
[/QUOTE]

Quote:
Originally Posted by brianbremer View Post
It will be a couple of days before I can build and send over the special firmware to test this. If you want to go this route PM me your email and I will send a link to the firmware once it is ready.
I'm in! I'll PM my addy and we'll go from there! Thanks so much for being willing to help out!
rusirius is offline        Reply With Quote Quick reply to this message
Old 04-22-2021, 07:08 PM   #10 (permalink)
Registered Users
 

Join Date: Aug 2020
Location: Germany
Default

Hi,

just stumbled across this post.

I am considering putting an unisens-e into a goblin fireball 280 build.
Anyway It would be great to know if this will work or not before getting started.

Though the last answer here is quite old maybe you guys can confirm if it would work or not?

Thanks alot!
Ptexas likes this.
HuiHui is offline        Reply With Quote Quick reply to this message
Reply

Tags
fc 6250hx, sm-modellbau unisens-e, telemetry




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1