Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > FrSky


FrSky FrSky product discussion.


Like Tree2Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 04-04-2021, 01:38 PM   #1 (permalink)
Registered Users
 

Join Date: Feb 2011
Default Range issue x6r/x8r (many receivers have gone bad)

Hello.
Four of my x4r receivers are dead. Now I use x6r and x8r. They never die. But I have range problems.
I have belt driven helis g420,g570 and gaui x3. I have anti static grounding from tail boom to battery - connector through fbl pin. It helps me to avoid sudden failsafe with high RSSI.
I crashed on this holidays my goblin 570 close to me at 10 meters. Range test of x8r from g570 is about 2-3 meters. I have also 3 x6r with low range.
I have good receivers with high RSSI, so it is not radio issue.
I change many receivers.
My opinion is that Frsky receivers are crap
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-05-2021, 12:09 PM   #2 (permalink)
Registered Users
 
Posts: 3,446
 

Join Date: Mar 2012
Location: Wauwatosa, WI
Default

Can you post a picture of how you have the antenna's mounted on a heli you're having issues with? I've never had issues with FrSky receivers unless I've damaged them. If you're having consistent problems across many models and receivers, then it's either your transmitter or how you have the antenna's mounted.
Helique and Number like this.
__________________
P Max v2, XL520, P380, XK K110, Open-TX
JWeber is offline        Reply With Quote Quick reply to this message
Old 04-06-2021, 05:15 AM   #3 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

In 2 plastic tubes. One tube on buttom frame, second antenna on right frame. I removed receiver, heli is in country house now, not at home. I have old photos. Main frame on 570 is stock glass fiber
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20210406-121222_1617700489134.png
Views:	56
Size:	1.57 MB
ID:	911953   Click image for larger version

Name:	Screenshot_20210406-121205_1617700543958.png
Views:	49
Size:	1.63 MB
ID:	912093   Click image for larger version

Name:	Screenshot_20210406-121257_1617700467910.png
Views:	42
Size:	1.93 MB
ID:	912095  
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7

Last edited by miron; 04-07-2021 at 02:49 AM..
miron is offline        Reply With Quote Quick reply to this message
Old 04-07-2021, 12:53 PM   #4 (permalink)
Registered Users
 
Posts: 3,446
 

Join Date: Mar 2012
Location: Wauwatosa, WI
Default

I always try and get the antenna away from the main body of the heli to prevent shadowing. Here's how I do it on my Goblin.



Attached Thumbnails
Click image for larger version

Name:	antenna 1.jpg
Views:	161
Size:	459.2 KB
ID:	912163   Click image for larger version

Name:	antenna 2.jpg
Views:	171
Size:	407.7 KB
ID:	912165  
__________________
P Max v2, XL520, P380, XK K110, Open-TX
JWeber is offline        Reply With Quote Quick reply to this message
Old 04-07-2021, 04:25 PM   #5 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

Goblin 570 has glass frame it is not electrical conductivity. Boom is connected to main frame on 570, but electic charge can't go to body, because it is glass. Therefore I've connected battery minus to tail boom. It halped me to not have fail-safe in flight on 570. I haven't problems for a long time. But fail-safe problem appeared again.
Goblin 420 has carbin frame, but boom is isolated. I have connected tail case to main frame on g420 and solved problems with fail-safe on spool up
Attached Thumbnails
Click image for larger version

Name:	GIUbeso9owk.jpg
Views:	31
Size:	1.73 MB
ID:	912219   Click image for larger version

Name:	W4TtFHjeLUg.jpg
Views:	32
Size:	1.78 MB
ID:	912221  
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7

Last edited by miron; 04-07-2021 at 05:11 PM..
miron is offline        Reply With Quote Quick reply to this message
Old 04-07-2021, 05:21 PM   #6 (permalink)
Registered Users
 
Posts: 3,446
 

Join Date: Mar 2012
Location: Wauwatosa, WI
Default

In that first picture, you could get some shadowing from the landing gear or the model (aluminum, motor, servos, etc.) itself if it's facing you with the nose slightly down. I've never had an issue with how I mounted my antenna.
__________________
P Max v2, XL520, P380, XK K110, Open-TX
JWeber is offline        Reply With Quote Quick reply to this message
Old 04-07-2021, 05:53 PM   #7 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

I have problem not with shading. New receiver has RSSI 70-80, old 40-50 in same place. Old receiver lost signal at 10 meters. One recevier doesn't work at all.
Good receiver will work with shading.
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 11:48 AM   #8 (permalink)
Registered Users
 

Join Date: Nov 2008
Default

I hope you find the problem. I have been chasing the same problem for more than a year now. Every once in a while my Goblin 420 using an x4rsb would loose connection and crash. After that, the rssi numbers for that receiver would drop really low and no longer be usable. I tried everything to eliminate static and magnetic interference but nothing solved the issue. Killed 3 x4rsbís. Decided to try an x8r and that seemed to have cured the problem until yesterday. The difference this time is my rssi numbers for the x8r still look ok. I never received a signal warning only got the telemetry lost notification and the rx went into failsafe. This was verified in my Ikon2 log. I suppose itís possible this time is not related to the other rx failures considering the x8r doesnít seem to be unusable like the x4rsbís. I obviously donít trust it though. Luckily, I was able to auto down this time, but might not be next time.
Xtremespeed is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 12:27 PM   #9 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

Hello.
My friend gave me x4r in shrink tube and it hasn't died after 10 flights. My three x4r in paper stock cover died. I'm using x6r and x8r. They live longer, but some times lose signal strength. I think that plastic case gives protection. Goblin 420 flies without problems with anti-static connection.

Try to connect tail case to mainframe and check conductivity by multimiter. Some times carbon hasn't conductivity on surface without sanding.

I checked my 570, bolt on tail boom on left and right side lost connection to carbon in boom. I connected side bolts on boom to battery minus before. I changed connection on 570. Now tail case is connected by wire to upper metal frame (side frame are glass). 4 flights on 570 without problems, it is not enough to say that all is good. I will test it more and write about it.
You can set RX to use Rescue in fail-safe. This helped me some times. But last crash not, because fail safe was too short and brain stoped rescue at Signal OK state.
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7

Last edited by miron; 04-21-2021 at 12:41 PM..
miron is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 01:22 PM   #10 (permalink)
Registered Users
 

Join Date: Nov 2008
Default

Thanks for the reply. I have already made mods to insure tail and boom are grounded to prevent static strikes. This did not help me. Only changing to x8r seemed to help but now suspect problem has returned.
Xtremespeed is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 04:34 PM   #11 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

I haven't problems with antistatic connection and x6r for a long time, but connection between boom and grounding was lost. Hope, you will find reason of your problem
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 04:45 PM   #12 (permalink)
Registered Users
 

Join Date: Nov 2008
Default

So far I’ve found it almost impossible to diagnose. I might make 20 flights or more before it happens. Works perfect for many flights and then for no apparent reason I get another failsafe. I also travel full time and have had the issue in several different geographic areas so I think I should be able to rule out interference. Very hard to duplicate. Out of curiosity what ISRM and receiver firmware are you using and which radio?

Oops. I see you have a qx7. Which firmwares though?
Xtremespeed is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 04:58 PM   #13 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

FW x7-2.3.11-otx - radio
X8R_150115- receiver
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Old 04-21-2021, 06:08 PM   #14 (permalink)
Registered Users
 

Join Date: Nov 2008
Default

I meant the firmware for the internal module (ISRM) and the ACCST receiver firmware. Likely 1.1.3 or 2.1.0. Was basically wondering if you were still on version 1 or on version 2 of the ACCST receiver firmware.
Xtremespeed is offline        Reply With Quote Quick reply to this message
Old 04-22-2021, 06:04 AM   #15 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

I'm using old firmware. I am confused by versions and differences. Newes firmware for receivers doesn't work with radio. I havent updated radio FW.
But problems with receivers are hardware
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Old 04-25-2021, 03:37 AM   #16 (permalink)
Registered Users
 
Posts: 13,965
 

Join Date: Dec 2011
Default

Has to be somthing the OP is doing to cause a rash of receiver deaths otherwise this would be repeated for everyone and it's not.

I recall Extrapilot saying some component on the RX4R is very sensitive to static discharge from the antenna so if the way you are setting up your helicopters causes static discharge from the antenna tips rather that some other place on the heli (static likes to jump off the ends of pointy things) that could be the issue.

Grounding the tail will NOT help here, grounding distributes static evenly but it will still reach the point where electrons will jump off from somewhere on the airframe. The only solution is a static wick which provides a pointy spot that static will preferentially jump off the airframe from. Static wicks are how they solve this issue in full scale aircraft.

An easy way to make a static wick is to crimp a piece of CF tow line into a ring terminal and fray the end then put it on a screw where it hangs off the edge of the frame into open air. The tiny ends of the fibers will allow electrons to jump off at relatively low energy levels.
Atomic Skull is offline        Reply With Quote Quick reply to this message
Old 04-25-2021, 04:23 AM   #17 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

I placed antennas of X4R in plastic tubes with shrink tube at the end. Buttom plate of my heli is plastic, side frame is glass fiber. On antenna is place on buttom and one on side
X4R from my friend with body in shrink tube did not die.
Noe antennas of X6R and X8R also are in tubes, but without grounding this receivers could loose signal or get fail-safe
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Old 05-22-2021, 03:19 PM   #18 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

I've added Batterry Cells sensor to my protos 500. Boom is grounded to mainframe. I had no problems without sensor. But with sensor I had fail safe(rescue in MSH brain helped to save heli in RX fail state). Receiver didn't worked at close range. Only power reset helped. I removed wire from receiver to sensor. Now it works fine, but rssi level is lower, than new receiver
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Old 05-22-2021, 07:51 PM   #19 (permalink)
Registered Users
 

Join Date: Nov 2008
Default

Some of the receivers I had that went bad, had very low rssi afterwards. Thatís part of what makes me think it could be static that caused the issue. My son recently had an x8r go into failsafe on a Goblin 420 for no apparent reason, after probably 70 flights with no changes, and flying in an area he frequents. Nothing in the ikon logs that looks suspicious other than rx failsafe. Not everyone has these problems with Frsky but Iíve seen enough including mine and my sons to make me seriously consider switching to another brand. I donít want to. I love the radio and Open Tx but Iím loosing confidence in them for helis. So far not one issue in electric prop planes or edfís. I wish Frsky had customer service to help us with issues and at least determine the cause.
Xtremespeed is offline        Reply With Quote Quick reply to this message
Old 05-23-2021, 03:47 AM   #20 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2011
Default

Quote:
Originally Posted by Xtremespeed View Post
Some of the receivers I had that went bad, had very low rssi afterwards. That’s part of what makes me think it could be static that caused the issue. My son recently had an x8r go into failsafe on a Goblin 420 for no apparent reason, after probably 70 flights with no changes, and flying in an area he frequents. Nothing in the ikon logs that looks suspicious other than rx failsafe. Not everyone has these problems with Frsky but I’ve seen enough including mine and my sons to make me seriously consider switching to another brand. I don’t want to. I love the radio and Open Tx but I’m loosing confidence in them for helis. So far not one issue in electric prop planes or edf’s. I wish Frsky had customer service to help us with issues and at least determine the cause.
I think that tail belt had some wear that caused static. I also hadn't problems on new gpblin 420, but after 50 flights I had problems
Opentx is good platform, but Frsky hardware is cnot so good.
You can try to place antennas in isolation from main frame and connect main frame to tail case by wire as it done on pictures above.
Without antistatic wiring I had failsafe on spool up. That is, the problem has progressed. First failsafe was in flight, after some time I had failsafe at each spool up.
__________________
Goblin 570, HW platinum 100A HV v3, Quantum 4125 560kv, 24t pinion, Align bl815h cyclic, KST DS515MG tail, Ikon 2 , 12s 3300mah, ~ 3.8 kg
Gaui x3, xnova 2618 1860kv, HW 50A, Ikon
Taranis qx7
miron is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1