Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Futaba Radios and Electronics


Futaba Radios and Electronics Futaba Radios, Gyros, Servos, Etc.


Reply
 
LinkBack Thread Tools Display Modes
Old 07-08-2021, 08:58 AM   #1 (permalink)
Registered Users
 
Posts: 4,666
 
My HF Map location
Join Date: Nov 2010
Location: Coral Springs , Florida
Default issue , not sure why

so yesterday i flew my xl power 550 with cgy760 and about 1 minute before the end of the flight the motor shut off and i crashed (luckily i managed to get it upright and broke the skids and blades only(so far), checked the tribunus log and it went to 10%throtttle for a split second then i hit throttle hold and it went to zero, but there is no reason that i can see why, when i got to the heli everything was working and it also tried to spool up when i took it off throttle hold.
this morning i flew my oxy 3 with an icon and hobbywing esc, at the end of the fourth flight as i was coming in to land the same thing happened , it went to very low throttle and luckily again i was almost at the point of hitting throttle hold when it went slow , it landed and kept turning but not enough for any lift, i hit throttle hold and it stoppped but it wouldn't spool back up when i switched it off. i checked the battery and it was at 3.7+ mah.
so now i'm thinking that there is a problem with my 18sz, do i need to send it in to get checked?or is there a setting that i might have missed even though its been flying for years without a problem.
even though its unlikely to be both systems i'm going to check the solder joints on the heli's just to rule that out
__________________
Anthony
logo 480 , xl power 550 x2 , cgy760-r , futaba
anthony1 is online now        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-10-2021, 08:44 PM   #2 (permalink)
Registered Users
 
Posts: 4,666
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2010
Location: Coral Springs , Florida
Default

well i found one issue with my elevator servo, not sure what its been rubbing on , could be the canopy but thats been fixed, is this enough to shut down the whole heli, i have an r2 buffer pack which obviously allowed me to straighten the heli before impact but when i got to the heli everything was working but the motor definately shut off.
i didn't find anything with the oxy 3 but i went ahead and changed the ec3 plug on the esc i had 2 flights this morning and all is well (so far) not sure what else to do >
Attached Thumbnails
Click image for larger version

Name:	20210710_203458.jpg
Views:	30
Size:	1.03 MB
ID:	923855  
__________________
Anthony
logo 480 , xl power 550 x2 , cgy760-r , futaba
anthony1 is online now        Reply With Quote Quick reply to this message
Old 07-10-2021, 10:44 PM   #3 (permalink)
Registered Users
 
Posts: 1,316
 

Join Date: Sep 2011
Location: Austin, Texas
Default

Good catch!
__________________
IRCHA 4503 AMA 831578
Align, XK Futaba, Hobbywing, iCharger, Chargery
Loud, sudden noises in a helicopter, WILL get your undivided attention
mlp3028 is offline        Reply With Quote Quick reply to this message
Old 07-13-2021, 08:40 AM   #4 (permalink)
Registered Users
 

Join Date: Mar 2013
Default

Sounds like your esc is hitting the low voltage cut off.
jtarpinian is offline        Reply With Quote Quick reply to this message
Old 07-13-2021, 09:56 AM   #5 (permalink)
Registered Users
 
Posts: 4,666
Thread Starter Thread Starter
 
My HF Map location
Join Date: Nov 2010
Location: Coral Springs , Florida
Default

i have it set to reduce power to 75% when it hits lvc and it just shut off , i'm sure the elevator servo was shorting out , possibly rubbing the canopy but is this enough to (and i hate to say it )brown out the system briefly, everything was working when i got to the heli , the motor even spooled up
__________________
Anthony
logo 480 , xl power 550 x2 , cgy760-r , futaba
anthony1 is online now        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1