Fun, Learning, Friendship and Mutual Respect START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > EGODRIFT


EGODRIFT Support Forum


Like Tree23Likes
  • 3 Post By Rabid121
  • 1 Post By Smoggie
  • 1 Post By EGODRIFT
  • 5 Post By Hicksy
  • 3 Post By Edge67
  • 1 Post By Ace Dude
  • 1 Post By EGODRIFT
  • 1 Post By Ace Dude
  • 1 Post By Ace Dude
  • 1 Post By Mike656
  • 1 Post By OICU812
  • 1 Post By AndyO
  • 3 Post By Hicksy
Reply
 
LinkBack Thread Tools Display Modes
Old 10-13-2021, 07:49 PM   #1 (permalink)
Registered Users
 

Join Date: Jul 2010
Default Does Egodrift work with Kontronik?

Has anyone had any trouble running Egodrift motors with Kontronik ESC?

I have a Logo 690SX with a Kontronik Heli Jive 120 ESC and an Egodrift 4525-370kv but the hili wonít spool up properly. I know the ESC is fine because I took it off and used it on a different heli and it worked perfectly.

All connections etc are good, Iím wondering if thereís a compatibility issue between Kontronik and Egodrift?
Hicksy is offline        Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-14-2021, 02:57 AM   #2 (permalink)
Registered Users
 
Posts: 1,592
 

Join Date: Oct 2011
Location: ~Vienna, Austria
Default

do you have another esc brand you could check the motor with? i guess you already have tested with KSA mode (there was an issue with HeliJive and some motors)? did you play around with fixed timing? (8-10*, the Egodrift motors do like low timing), maybe it's just loosing commutation sync....

Ciao
Michael
Hicksy, Smoggie and EGODRIFT like this.
__________________
our hangar: minicopter & Logo helis, YGE/Egodrift/Spirit/Futaba BLS/Jeti
Rabid121 is online now        Reply With Quote Quick reply to this message
Old 10-14-2021, 03:04 AM   #3 (permalink)
Registered Users
 

Join Date: Nov 2013
Location: Aberdeen, UK
Default

An incompatibility issue is certainly possible. I have in the past had an ESC and motor combo that wouldn't play nice together, but both worked fine with other hardware.

Could it be the auto timing causing problems. Is there an option to set fixed timing on the ESC? Otherwise yeah, try a different ESC for testing purposes. You could use a small/cheap ESC if you are just test spooling the motor on the bench.
Hicksy likes this.
__________________
Gob Kraken |Gob 700 BT 'T' | Gob 770 Comp | SoXos Strike 7 | Henseleit TDR, TDSF & TDR2 | Kasama Dune | OMP M1&M2 | UK stockist for OMPHobby M1/M2 ScotiaRC.co.uk
Smoggie is online now        Reply With Quote Quick reply to this message
Old 10-14-2021, 04:39 AM   #4 (permalink)
Registered Users
 
Posts: 75
 

Join Date: May 2019
Location: Austria
Default

Hi Hicksy,

first of all let me say that I am sorry for the troubles you're having.

Our motors generally run very well with Kontronik escs, the only issue ever that I am aware of was related to one or two generations of the old Jive 80A escs (potentially on a specific firmware) and our 4025HS motors.

The esc would in this case output a very cryptic error message (reproducible over several units of the same esc and units of our motors), which Kontronik support denied even existed. The error message would read:

"Induktivität des Motors im Verhältnis zur Akkuspannung zu niedrig. Akkuspannung reduzieren, selber Motor mit mehr Windungen einsetzen."

("Inductance of the motor too low in relation to the battery voltage. Reduce battery voltage, insert same motor with higher turn count.")

The fix for this was to insert an additional anti-spark (or remove an existing one, can't remember exactly - it's been years since this case) and/or to plug in the connectors very slowly.

I am not aware of any issues with either the 120A version of that esc or any other motor than the 4025HS though, to my knowledge the issue was specific to the combination indicated above (and not even all instances of it).

In order to help you with this problem:

1) Do you have a different (non Jive-) esc to test this motor with?
2) I assume you updated the esc to the latest firmware
3) Also, I understand you bought this motor used, so maybe you could send me some details on who you purchased this motor from (via pm), this might help me shed some light onto the history of the motor.

Thank you very much in advance and I'm sure we'll be able to get to the bottom of this in no time,

kindest regards

Vincent
Hicksy likes this.
__________________
Vincent Offenbeck
EGODRIFT Brushless Motors | Official Account
Please feel free to contact us for questions & support,
or visit www.egodrift.com
EGODRIFT is offline        Reply With Quote Quick reply to this message
Old 10-15-2021, 12:40 AM   #5 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2010
Default

Cheers Michael,
I donít have another brand but I do have a newer Power Jive which Iíll try next - just waiting on a few other parts to arrive then Iíll set up the Power Jive and see how that goesÖ

Cheers Smoggie,
As above Iíll try the Power Jive instead of the Heli Jive - maybe itís running newer firmware, Iím not sure as Iíve never updated these ESCís since Iíve had them. I do have a Hobbywing 60 ESC I could try but even with the Heli Jive the motor would spool up fine on the bench with no blades on - itís only when I add blades it doesnít spool up properly. But Iíll check the Power Jive anywayÖ

Cheers Vincent,
I sincerely appreciate your customer service in helping me with this - as well as your time in helping me with trouble shooting via private message - definitely above and beyond so thank you very much! Iíll keep you posted on my progress as I change out the Heli Jive with the Power Jive and update the firmwares etcÖ

Thanks again for all of your input and advice - much appreciated!
Hicksy is offline        Reply With Quote Quick reply to this message
Old 10-21-2021, 07:04 AM   #6 (permalink)
Registered Users
 
Posts: 458
 

Join Date: Jul 2017
Default Great success for me

I have run that combination alot on my Gaui X7 and also my Comet, Diabolo S, and my Raw.
Attached Thumbnails
Click image for larger version

Name:	IMG_5784.JPG
Views:	31
Size:	4.95 MB
ID:	937471   Click image for larger version

Name:	IMG_5786.JPG
Views:	33
Size:	3.59 MB
ID:	937473  
Hicksy, jrman83 and EGODRIFT like this.
__________________
EGODRIFT // ManiaX
Xpert RC USA // KBDD
www.HeliDirect.com
Edge67 is offline        Reply With Quote Quick reply to this message
Old 10-21-2021, 07:36 AM   #7 (permalink)
Registered Users
 

Join Date: Sep 2004
Default

@EGODRIFT - Do you think using a specific timing might help in this situation?
Hicksy likes this.
Ace Dude is offline        Reply With Quote Quick reply to this message
Old 10-21-2021, 05:02 PM   #8 (permalink)
Registered Users
 
Posts: 75
 

Join Date: May 2019
Location: Austria
Default

Hi AceDude,

honestly: I doubt it. While Kontronik's auto-timing has the habit of running motors a couple degrees warmer than fixed timing does (this pretty much goes for all auto-timings and motors, it just appears to be in the nature of most software implementations), it usually works without any flaws and I can see the added benefit (ease of use) that justifies the trade-off (let alone that Kontronik's governor is pretty good).

The situation in Hicksy's case is especially weird, as we don't only know that both the esc and motor work - they even did so together on 6S first, and then (according to Hicksy) an awesome full flight on 12S - so my best guess at this time is that there is some problem in the software/settings/firmware, maybe from the switch of cell count (6 to 12S) but we'll dive deeper into this and keep this thread updated in case anybody ever runs into an issue like that in the future.

The few isolated incidents are all related to old Jives, I'm not aware of any issue ever with any of the newer escs (Jive Pro, Kosmik and up)...

kindest regards

Vincent
Hicksy likes this.
__________________
Vincent Offenbeck
EGODRIFT Brushless Motors | Official Account
Please feel free to contact us for questions & support,
or visit www.egodrift.com
EGODRIFT is offline        Reply With Quote Quick reply to this message
Old 10-21-2021, 09:19 PM   #9 (permalink)
Registered Users
 

Join Date: Sep 2004
Default

I sent Hicksy a PM with some questions to get a better of understanding of how the ESC is responding.
Hicksy likes this.
Ace Dude is offline        Reply With Quote Quick reply to this message
Old 10-23-2021, 07:04 AM   #10 (permalink)
Registered Users
 

Join Date: Sep 2004
Default

Hi Hicksy,

Can you please try using KSA mode (mode 9) in the Heli Jive?
Hicksy likes this.
Ace Dude is offline        Reply With Quote Quick reply to this message
Old 10-23-2021, 07:31 AM   #11 (permalink)
Registered Users
 

Join Date: Nov 2013
Location: England
Default

Hi Hicksy
My setups with Egodrift motors across a range of K escs (Kosmik, Jive Pro, Jive and Kolibri) all work flawlessly. Have you looked at the max starting current under Expert settings on K-Prog?
Hicksy likes this.
Mike656 is offline        Reply With Quote Quick reply to this message
Old 10-25-2021, 06:16 AM   #12 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2010
Default

Yep I tried KSA mode, didn’t change anything at all…
Hicksy is offline        Reply With Quote Quick reply to this message
Old 10-25-2021, 06:23 AM   #13 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2010
Default

Hi Mike656,

No mate I havenít looked at that yet, Iím in the process of organising the gear I need to look at and upgrade the firmware etc as I havenít done any of that at all since I purchased the ESC.

In the interim Iím going to put a newer Power Jive on the heli with the Egodrift motor and see how it goes

Iím away for work at the moment though so wonít be able to try it for a few weeks but Iíll keep you posted once I get back home and try it.

Thanks again to you and all who have contributed here - I really do appreciate it!

Hicksy
Hicksy is offline        Reply With Quote Quick reply to this message
Old 10-26-2021, 08:23 PM   #14 (permalink)
Registered Users
 
Posts: 10,281
 
My HF Map location
Join Date: Oct 2005
Location: Grande Prairie, Alberta
Default

Will be interested to see result here. In past I did have different motors play not nicely with different escs, and oddly enough they were with Kontronik escs lol. I was for years a pilot for the big K, very good escs but certainly some small fine oddities as well, I recall getting them to consider a mode creation to handle FBL governor handling and that was like someone was burning down their house for them to accept lol. Hopefully this is more firmware based as discussed.



That all said opens up for me at least an interesting question for Vincent which is (what escs consistently work well with the Egodrift line?) I guess that would be what have you never heard of issue with as far as compatability?
Hicksy likes this.
__________________
...Once upon a time there were Nitros, flybars & frequency pins...Shawn
OICU812 is offline        Reply With Quote Quick reply to this message
Old 11-01-2021, 05:41 PM   #15 (permalink)
Registered Users
 
Posts: 2,364
 

Join Date: Jun 2016
Default

Kosmik HV and Kolibri LV - all have worked flawlessly with my EGODRIFT motors
Hicksy likes this.
__________________
Synergy 696
Minicopter Triabolo 700BE
MSH Protos 380Evo
MSH Brain2 Beta Team & Egodrift Team
AndyO is offline        Reply With Quote Quick reply to this message
Old 11-26-2021, 04:46 AM   #16 (permalink)
Registered Users
Thread Starter Thread Starter
 

Join Date: Jul 2010
Default

Hi All,

For those who were interested Iím sorry Itís been a while, I work away from home on a remote Mine site and work has been hectic!

I did try my newer Kontronik Power Jive 120 and it behaved exactly the same as my older Kontronik Heli Jive 120.

So then I borrowed my friends Hobbywing 130a ESC and I can confirm that my Egodrift motor worked perfectly - spooled up perfectly and flew, no troubles whatsoever!

It definitely seems as though the Kontronik ESCís I have were either incompatible or simply needed the firmware updated. Either way I donít mind, Iíll just use them with Pyro motors which is a great combo anyway so itís all good.

Iím still away at work now but I ordered my own Hobbywing 130a ESC which has arrived and as soon as I get back home Iíll install it on the Logo 690 and get it flying - I canít wait!!

Thanks again to Vincent from Egodrift and everyone else in this forum for the help and support - I really do appreciate it
Thunder Fighter, jrman83 and AndyO like this.
Hicksy is offline        Reply With Quote Quick reply to this message
Reply




Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the HeliFreak forums, you must first register.
Please enter your desired user name, your REAL and WORKING email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself. Use a real email address or you will not be granted access to the site. Thank you.
Email Address:
Location
Where do you live? ie: Country, State, City or General Geographic Location please.
Name and Lastname
Enter name and last name here. (This information is not shown to the general public. Optional)
Helicopter #1
Enter Helicopter #1 type and equipment.
Helicopter #2
Enter Helicopter #2 type and equipment.
Helicopter #3
Enter Helicopter #3 type and equipment.
Helicopter #4
Enter Helicopter #4 type and equipment.

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Copyright © Website Acquisitions Inc. All rights reserved.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.

SEO by vBSEO 3.6.1